Dans cet article, nous allons examiner comment configurer et utiliser le logiciel réseau GNS3 (Graphical Network Simulator 3), qui est utilisé pour préparer professionnellement les examens Cisco sur un ordinateur équipé du célèbre système d’exploitation Debian.

SOMMAIRE:

Comment télécharger et installer GNS3 ?

Avant d’installer le programme de simulation de réseau sur Debian, vous devez mettre à jour les adresses de votre dépôt, puis télécharger et installer le logiciel via PyPI (Python Package Index) via pip3.

Etape 1

Sur votre système Debian, recherchez le terminal dans la section Activités, trouvez-le et exécutez-le. Après avoir ouvert le terminal dans votre environnement de bureau Gnome, exécutez la commande “sudo apt update” et mettez à jour la liste des logiciels.

Comment installer GNS3 sur Debian 

Etape 2

Après avoir rafraîchi les adresses du dépôt, puisque vous allez télécharger GNS3 sur votre système à l’aide de pip3, exécutez la commande ci-dessous dans le terminal pour installer python3 et les paquets supplémentaires.

sudo apt install python3-pip python3-pyqt5 python3-pyqt5.qtsvg python3-pyqt5.qtwebsockets qemu qemu-kvm qemu-utils libvirt-clients libvirt-daemon-system virtinst wireshark xtightvncviewer apt-transport-https ca-certificates curl gnupg2 software-properties-common -y
Comment installer GNS3 sur Debian 

Etape 3

Pour télécharger et installer le logiciel réseau GNS3 sur votre ordinateur à l’aide de pip3, exécutez la commande “sudo pip3 install gns3-server gns3-gui” dans le terminal et attendez que le téléchargement soit terminé.

Comment installer GNS3 sur Debian 

Étape 4

Vous devez également installer le logiciel Dynamips nécessaire pour GNS3, sinon, vous ne pourrez pas émuler les images de routeur ou de commutateur sur votre ordinateur.

Pour télécharger et installer Dynamips à partir du dépôt Debian, exécutez les commandes ci-dessous dans le terminal.

wget http://ftp.us.debian.org/debian/pool/non-free/d/dynamips/dynamips_0.2.14-1_amd64.deb
sudo dpkg -i dynamips_0.2.14-1_amd64.deb
Comment installer GNS3 sur Debian 

Étape 5

Après avoir installé le logiciel réseau GNS3 sur votre ordinateur Linux, trouvez-le dans le menu de démarrage et exécutez-le.

Comment installer GNS3 sur Debian 

Étape 6

Après avoir ouvert le GNS3, l’assistant de configuration apparaît. Dans cette fenêtre, vous devez choisir d’exécuter les images IOS sur le serveur local ou le serveur virtuel.

Pour exécuter les appareils IOS sur le serveur local, sélectionnez Exécuter les appareils sur mon ordinateur local et cliquez sur Suivant.

Comment installer GNS3 sur Debian 

Étape 7

Ne modifiez pas le paramètre Server Path dans la fenêtre Local Server Configuration et cliquez sur Next après avoir vérifié que le paramètre Host Binding est localhost.

Par ailleurs, si un logiciel tiers est installé sur votre système et qu’il utilise le port TCP 3080, vous pouvez modifier le numéro du port pour que le logiciel fonctionne correctement.

Comment installer GNS3 sur Debian 

Étape 8


Cliquez sur Suivant après avoir vérifié que la connexion est réussie dans la fenêtre État du serveur local. Dans la fenêtre Résumé, vérifiez les paramètres que vous avez définis et fermez l’assistant.

Comment installer GNS3 sur Debian 

Comment ajouter une image IOS Cisco ?

Après avoir installé GNS3 sur votre ordinateur Debian et vous être connecté au serveur local, tout ce que vous avez à faire est d’ajouter une image IOS de routeur ou de commutateur au programme.

Étape 1

Cliquez sur Édition / Préférences dans le menu d’outils du programme GNS3.

Comment installer GNS3 sur Debian 

Étape 2

Vous pouvez vérifier qu’il y a plusieurs paramètres dans la fenêtre Préférences du panneau de gauche. Pour ajouter un périphérique iOS, cliquez sur Routeurs IOS sous Dynamips, puis cliquez sur le bouton Nouveau pour ouvrir l’assistant.

Lorsque l’assistant Nouveau modèle de routeur IOS s’ouvre, cliquez sur Parcourir pour ajouter le fichier IOS.

Comment installer GNS3 sur Debian 

Etape 3

Sélectionnez le fichier IOS c7200-adventerprisek9-mz.152-4.M7.bin ou tout autre fichier que vous avez téléchargé sur votre ordinateur et ouvrez-le.

Comment installer GNS3 sur Debian 

Étape 4

Cliquez sur Oui pour confirmer la décompression de l’image IOS et attendez le processus de décompression.

Comment installer GNS3 sur Debian 

Étape 5

Après avoir spécifié l’emplacement de l’IOS, cliquez sur Suivant et passez aux autres paramètres.

Comment installer GNS3 sur Debian 

Étape 6

Vous pouvez voir le nom du périphérique IOS que vous avez sélectionné dans la section Nom de la fenêtre Nom et plate-forme. Si vous comptez ajouter plus d’un modèle de périphérique au programme, changez le nom du périphérique dans la section Nom et modifiez sa plate-forme.

Comment installer GNS3 sur Debian 

Étape 7

En fonction de la taille de la mémoire vive de votre ordinateur hôte, configurez une taille de mémoire appropriée afin que le périphérique Router IOS puisse travailler plus efficacement et être plus performant.

Comment installer GNS3 sur Debian 

Étape 8

Si vous souhaitez ajouter des interfaces supplémentaires au routeur que vous avez ajouté, vous pouvez les sélectionner dans les sections Slot de la fenêtre Network Adapters.

Comment installer GNS3 sur Debian 

Étape 9

La valeur Idle-PC est une configuration nécessaire pour que le périphérique IOS n’utilise pas 100 % du processeur de votre ordinateur. Par conséquent, pour déterminer la valeur Idle-PC pour le c7200 en fonction des performances de votre PC, cliquez sur le bouton Idle-PC Finder et attendez que la valeur appropriée soit trouvée.

Comment installer GNS3 sur Debian 

Étape 10

Après avoir ajouté le périphérique Router c7200, lorsque vous vérifiez le paramètre Server, vous pouvez voir que le périphérique fonctionnera en Localhost.

Comment installer GNS3 sur Debian 

Comment résoudre l’erreur uBridge

Vous pouvez rencontrer une erreur uBridge lorsque vous essayez de câbler les périphériques Router et Switch que vous avez ajoutés à l’espace de travail logique GNS3. La raison de cette erreur est que le paquetage uBridge n’est pas compatible avec la version de votre distribution Linux.

Étape 1

Lorsque vous connectez le commutateur au routeur, il se peut que vous obteniez l’erreur “Error while creating link : uBridge is not available, path doesn’t exist, or you just installed GNS3 and need to restart your user session to refresh user permissions.” comme dans l’image ci-dessous.

Comment installer GNS3 sur Debian 

Étape 2

Pour corriger l’erreur uBridge sur votre système Debian, vous devez d’abord installer les paquets nécessaires. Pour installer le paquet libpcap, exécutez la commande “sudo apt install libpcap-dev -y” dans le terminal.

Comment installer GNS3 sur Debian 

Étape 3

Après avoir installé le paquet libpcap, vous devez également installer le logiciel Git sur votre système pour télécharger et compiler le paquet uBridge via Git. Pour installer git, exécutez la commande “sudo apt install git -y” dans le terminal.

Comment installer GNS3 sur Debian 

Étape 4


Pour cloner uBridge via Github, allez d’abord à l’emplacement des téléchargements avec la commande “cd ~/Downloads” dans le terminal, puis exécutez la commande “git clone https://github.com/GNS3/ubridge.git”.

Après avoir cloné uBridge, allez dans le répertoire avec la commande “cd ubridge” et exécutez la commande “make” pour le compiler dans le répertoire.

Comment installer GNS3 sur Debian 

Étape 5

Enfin, exécutez la commande “sudo make install” dans le terminal pour configurer les autorisations et les paramètres nécessaires.

Comment installer GNS3 sur Debian 

Comment résoudre l’erreur “Aucun chemin d’accès à un exécutable VPCS n’a été défini” ?

Après avoir résolu le problème uBridge, lorsque vous exécutez tous les périphériques dans l’espace de travail, le VPCS que vous avez ajouté à la topologie ne fonctionne parfois pas, selon la distribution Linux que vous utilisez.

Étape 1

Lorsque vous exécutez tous les dispositifs de la topologie, vous obtenez l’erreur “No path to a VPCS executable has been set” (aucun chemin d’accès à un exécutable VPCS n’a été défini) comme dans l’image ci-dessous. Cela est dû au fait que le périphérique VPCS n’a pas été configuré correctement.

Comment installer GNS3 sur Debian 

Étape 2

Pour installer le VPCS sur votre ordinateur Debian, exécutez la commande “sudo apt install vpcs” dans le terminal.

Comment installer GNS3 sur Debian 

Comment corriger l’erreur de la version exécutable du VPCS ?

Lorsque vous exécutez à nouveau les périphériques réseau après avoir installé VPCS, vous pouvez obtenir une erreur concernant la version de VPCS cette fois-ci. L’erreur de version de l’ordinateur virtuel est due à la version Debian 11.

Étape 1

Lorsque vous exécutez les VPCS dans la topologie, vous obtiendrez l’erreur “VPCS executable version must be >= 0.6.1 but not a 0.8” dans l’image ci-dessous et vous ne serez pas en mesure de faire fonctionner les dispositifs.

Comment installer GNS3 sur Debian 

Étape 2

Pour résoudre le problème du VPCS sur les plateformes Linux, vous devez télécharger et installer une version appropriée. Pour installer la version 0.8.1 de VPCS, exécutez les commandes ci-dessous dans l’ordre dans le terminal.

Comment installer GNS3 sur Debian 

Étape 3

Après avoir installé l’ancienne version du VPCS, vous pouvez maintenant constater que tous les dispositifs de la topologie fonctionnent sans problème.

Comment installer GNS3 sur Debian 

Comment créer une topologie de réseau

Vous pouvez analyser la façon dont les ordinateurs du réseau communiquent en créant une conception de réseau simple et professionnelle à l’aide du logiciel GNS3.

Étape 1

Ouvrez l’assistant de projet en cliquant sur l’icône Nouveau ou sur CTRL + N dans le menu d’outils du GNS3. Donnez un nom adapté à la topologie du réseau que vous allez concevoir, indiquez l’emplacement où vous souhaitez enregistrer et cliquez sur OK.

Comment installer GNS3 sur Debian 

Étape 2


Pour ajouter deux routeurs c7200 à votre projet, cliquez sur Routeurs dans le panneau de gauche, puis faites glisser et déposez le périphérique dans l’espace de travail.

Comment installer GNS3 sur Debian 

Étape 3

Sélectionnez Ethernet Switch dans la catégorie Switches et ajoutez deux Switches à l’espace de travail.

Étape 4

Ouvrez la catégorie Tous les dispositifs et ajoutez deux VPCS (Virtual PC Simulator) à l’espace de travail.

Comment installer GNS3 sur Debian 

Etape 5

Pour ajouter une interface série aux ports vides des routeurs de la topologie, cliquez sur le bouton droit de la souris / Configurer sur ces ports.

Comment installer GNS3 sur Debian 

Étape 6

Dans la fenêtre Node Properties, sous l’onglet Slots, ajoutez PA-4T+ (Serial Interface) au port Slot1 dans la section Adapters et cliquez sur OK.

Comment installer GNS3 sur Debian 

Étape 7

Après avoir ajouté une interface série aux routeurs, activez l’option de câblage pour connecter les VPCS aux Switches et branchez une extrémité du câble dans le port Ethernet0 des PC et l’autre extrémité dans l’un des ports libres des Switches.

Comment installer GNS3 sur Debian 

Étape 8

De même, pour connecter les commutateurs aux routeurs, branchez une extrémité du câble dans les commutateurs et l’autre extrémité dans les ports FastEthernet0/0 des routeurs.

Étape 9

Pour connecter les routeurs Cisco, branchez une extrémité du câble sur le port Serial 1/0 de R1 et l’autre extrémité sur le port Serial 1/0 de R2.

Comment installer GNS3 sur Debian 

Étape 10

Après avoir câblé tous les appareils, cliquez sur la flèche verte du menu d’outils et cliquez sur Oui dans la fenêtre qui s’ouvre pour les exécuter.

Comment installer GNS3 sur Debian 

Étape 11

Pour ajouter des adresses IP statiques aux PC VPCS, cliquez sur ces derniers pour ouvrir l’invite CLI et configurer les paramètres TCP/IP de PC1 et PC2.

PC1> ip 192.168.1.10/24 192.168.1.1
PC1> show ip

PC1> ip 192.168.2.20/24 192.168.2.1
PC1> show ip
Comment installer GNS3 sur Debian 

Étape 12

Exécutez les commandes ci-dessous dans l’interface CLI pour attribuer des adresses IP aux ports FastEthernet des routeurs Cisco et les ouvrir.

R1# conf t
R1(config)# interface fastethernet 0/0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# no shutdown

R2# conf t
R2(config)# interface fastethernet 0/0
R2(config-if)# ip address 192.168.2.1 255.255.255.0
R2(config-if)# no shutdown
Comment installer GNS3 sur Debian 

Étape 13

Puisque vous connectez le routeur R1 et R2 avec le port d’interface série, configurez également ces ports.

R1# conf t
R1(config)# interface serial 1/0
R1(config-if)# ip address 192.168.3.1 255.255.255.0
R1(config-if)# no shutdown

R2# conf t
R2(config)# interface serial 1/0
R2(config-if)# ip address 192.168.3.2 255.255.255.0
R2(config-if)# no shutdown
Comment installer GNS3 sur Debian 

Etape 14

Lorsque vous effectuez un ping sur les ports série externes des routeurs à partir des PC, vous pouvez constater qu’il existe une connexion réseau.

PC1> ping 192.168.3.1

PC2> ping 192.168.3.2
Comment installer GNS3 sur Debian 

Étape 15

Cependant, comme l’un des protocoles de routage RIPv1/v2, IGRP, EIGRP ou OSPF ou une route statique n’est pas configuré sur les routeurs, vous ne serez pas en mesure de vous envoyer des ping à partir de PC et vous obtiendrez une erreur Destination host unreachable comme dans l’image ci-dessous.

PC1> ping 192.168.2.20

PC2> ping 192.168.1.10
Comment installer GNS3 sur Debian 

Étape 16

Vous pouvez vous connecter aux ordinateurs des deux sous-réseaux en configurant le protocole EIGRP sur les routeurs. Exécutez les commandes ci-dessous pour activer EIGRP dans l’invite de commande CLI des routeurs R1 et R2.

R1# conf t
R1(config)# router eigrp 10
R1(config-router)# network 192.168.3.0 0.0.0.255
R1(config-router)# network 192.168.1.0 0.0.0.255

R2# conf t
R2(config)# router eigrp 10
R2(config-router)# network 192.168.3.0 0.0.0.255
R2(config-router)# network 192.168.2.0 0.0.0.255
Comment installer GNS3 sur Debian 

Étape 17


Après avoir configuré le protocole EIGRP, vous pouvez constater que la connexion réseau est réussie lorsque vous vous envoyez à nouveau un ping depuis les PC.

Découvrez également:

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

16 − quatorze =

Captcha *Captcha loading...